Loading... Please wait...

Our Newsletter


Flashcarts Get Blocked after 3DS (XL) System V6.2.0-12A Update

Posted on 6th Aug 2013 @ 4:57 PM

Dear flashcart users:
3DS (XL) system Ver 6.2.0-12A is now blocking all flashcarts on market, please do not update your console until get your flashcart firmware upgraded for this 6.2 system.

Below flashcarts are tested on our 3DS 6.2.0-12A today, for more latest compatibility, please refer to our compatibility table.

Not-working Cards

DSTWO (www.supercard.sc, patch will be released soon)
R4i Gold 3DS RTS/V6.1/non-marking (www.r4ids.cn)
R4i SDHC 3DS RTS/V5.0/V4.5/V4.4/non-marking (www.r4i-sdhc.com)
R4i Gold Plus (www.r4ids.com)
R4 Gold Pro  (www.r4i-gold.com)
R4 Dual Core (www.r4isdhc.com)
R4itt (www.r4itt.net)