Loading... Please wait...

Our Newsletter


Sort by:

dsi (xl) up to 1.4.5

All flashcards in this category support all DSi XL / DSi system versions below, no need firmware upgrade.

  • DSi XL / DSi: Ver 1.3a/e, 1.4a/e, 1.4.1a/e, 1.4.2a/e, 1.4.3a/e, 1.4.4a/e, 1.4.5a/e

Of course, they can also work on your DS Lite or DS original.